Frequently Asked Questions

I cannot connect the G1000 Student and Prepar3D 2.2
Last Updated 6 years ago

Q. I have the G1000 Student 1.47 and Prepar3D 2.2 and I cannot establish a connection.

A. Please download the following file, extract the executable and run it on the P3D machine. This will update the network module to run with Prepar3D 2.2


Please Wait!

Please wait... it will take a second!